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CollabCAD Getting Started

1. Introduction

CollabCAD  is  a  Java  based  distributed  CAD/CAM  Software  System  developed  by 
Computer  Aided  Design   Group  of  National  Informatics  Center,  the  IT  Support 
professionals from India. CollabCAD is based on  well  proven Open domain technologies 
like Java, Java 3D, Java RMI, Open Cascade geometry kernel. 
  
CollabCAD facilitates the conventional CAD/CAM capabilities like design, drafting, surface 
and solid modeling, feature based modeling, basic NC features, data exchange, scripting 
etc. It offers both Part Design  and Assembly Design.

CollabCAD will  run on Windows and Linux platforms. It  is available as two 
modes:
1) CollabCAD Standalone – to work on standalone systems
2) CollabCAD Client-Server mode for collaborative designing and multiple
sharing.

2. System Requirement

RAM 1 GB (Recommended 2GB or more)

Free Disk 
Space

1 GB 

Virtual 
Memory

800 MB to 1 GB

Graphics 
Card

Open GL Supported Hardware Accelerated Graphics 
Adapter with 64 MB VRAM: Graphics Card based on 
Nvidia Chip set: Example- Asus

System Intel and AMD Based Systems

Operating 
System

 Windows NT/2000  (Server,  Professional) /  

 XP/Vista/7, Linux

The following Linux Operating System are supported
 

• Redhat 9.0
• RHEL 3.0, 5.5
• Mandrake 9.2, 10.0, 10.1, 10.2
• Mandriva 2006, 2008, 2010
• Ubuntu Desktop 8.04 (LTS), 8.10, 10.04, 11.04
• Ubuntu Server 8.10 
• BOSS Desktop 3.1 
• BOSS Advanced Server 1.0 

3. Download

CollabCAD can be downloaded from the site http://www.collabcad.g  ov.in   under Download 
section.  User needs to register himself for downloading CollabCAD. 
      
      a)  CollabCAD  with PLM - Windows
      b)  CollabCAD  with PLM -  Linux
      c)  CollabCAD  without PLM -  Linux
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4.  Installation 
  
     4.1  Installing CollabCAD on Windows 

You must have at least 800 MB of free disk space in the C:\TEMP directory. The 
installation will not proceed if this is not available. The installation would  require 
around 235 MB for "CollabCAD"  on the C Drive.

NOTE : TAKE CARE THAT THERE DOES NOT EXIST ANY BLANK SPACE IN THE  
FOLDER NAME  IN THE PATH WHERE YOU INSTALL COLLABCAD. (e.g C:\Program 
Files)

Double  click  the  CollabCAD.zip  file.  Extract  the  files  in  some  directory  (say  
c:\temp\disk1). 
Double click on setup.exe from the extracted files(In NT/2000 you should be  the 
administrator or should have the administrative privilege to install   this).  (say  
c:\temp\disk1\setup.exe)

The Installation wizard will guide you through the setup process.( Figure: 1 )

 Figure: 1

     4.2  Installing CollabCAD on Linux

You must have at least 400 MB free disk space on the /tmp file system in order to 
install CollabCAD.  The file size of collabcad_linux.tgz 265 MB and the installation 
would require around  800 MB .  After downloading the file, type the following  
command 

 tar -xvzf collabcad_linux.tgz 
This  will  install  CollabCAD on  your  system by  creating  the  directory  called   
collabcad. 
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5. Running CollabCAD

5.1  Running CollabCAD on Windows:

5.1.1 To start CollabCAD in Client-Server mode:
         

1. First Start the CollabCAD Application Server. To do this, Go to the start button on 
the task bar and follow the path:

Start ---> Programs ---> CollabCAD --> Start CollabCAD Server
This will start the CollabCAD application server in a DOS window. Make sure you 
see 'CollabCAD Application Server Ready' in this window, before launching the  
CollabCAD Application/Client. 

2. To Stop the CollabCAD Application Server, Go to the start button on the task bar 
and follow the path:-

Start ---> Programs ---> CollabCAD --> Stop CollabCAD Server
This will stop the CollabCAD application server. 

NOTE:-
1) The above mentioned path to start or stop the CollabCAD application server 

will start or stop the server on the following default argument values:-
RMI_Port=1099, DB_host=localhost, DB_port=3333

   
2) Please  note  that  improper  CollabCAD  Server  shutdown  or  stopping  the 

CollabCAD Application Server by Ctrl-C or directly closing the Dos Window may 
not start the CollabCAD server next time. It's because of the ".lock" file present 
in the \parts directory. This is present as a safeguard against multiple servers 
starting from the same location. This file is to be removed manually.

3. After starting the CollabCAD Server, start the CollabCAD application/Client. To start 
this, follow the path:-

Start ---> Programs ---> CollabCAD --> CollabCAD Client
Once the Application comes up, it will prompt for Login to CollabCAD server. 

NOTE:-

1) Starting the CollabCAD Application/Client by the above mentioned path will
       start the application/client  by the default CollabCAD Server hostname and port 

    number (i.e. localhost and 1099 respectively).

          2) If your ColllabCAD Server hostname or port number or both values are other than
   default ones, you can start your CollabCAD Application/Client on the specific     
  hostname or port number or both by editing your collabcadclient.bat which will be

              in the directory where you have installed CollabCAD.

5.1.2 To start CollabCAD in Standalone mode:

Start the CollabCAD Application in Stand-Alone Mode. To start this, follow the path:-

Start ---> Programs ---> CollabCAD --> CollabCAD Stand-Alone  
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5.2  Running CollabCAD on Linux:

5.2.1 To start CollabCAD in Client-Server mode:

1. First Start the CollabCAD Application Server. For this, do the following: -
Open a terminal. Change the directory to where CollabCAD is installed. Run the  
script “collabcad" as follows:   
 Usage: ./ collabcad [-options] [args...]

where options include:

No options starts the CollabCAD Application Client opens the part in stand-alone
          mode
            [--/-]listen    starts the CollabCAD Application Server
            [--/-]stop      stops the CollabCAD Application Server
            [--/-]help      prints this help message

example : ./collabcad -listen

    This will start the CollabCAD application server. Make sure you see 'CollabCAD
    Application Server Ready' in this window, before launching the CollabCAD

          Application/Client.

NOTE:-

1) The above script CollabCAD will start the CollabCAD application server on the
     following default argument values:-
     RMI_Port=1099, DB_host=localhost, DB_port=3333

2) If you wish to start or stop the CollabCAD Application server on the argument
     values other than default ones do the following:-
     Change the directory to where CollabCAD is installed.

     Run the script "CollabCAD" as follows:-
     ./collabcad [[--/-][listen/stop]] [RMI_port] [DB_host] [DB_port]

     If the port is already in use please use some other port(eg "./collabcad -listen -p
     1112") or contact your system administrator for using some other port.

3) To access CollabCAD application server from remote client systems, you need to do
     the following:-
     Add the IP Address and HostName of the Server in the hosts file (/etc/hosts) of

           Server system as a root user and restart the network service.

2. Start the CollabCAD Application/Client. To start this,

Open a new terminal for client side, run the script "collabcad". (make sure that 
you have done cd to CollabCAD directory)

./ collabcad

Once the Application comes up, it will prompt for Login to CollabCAD server. 

  
5.2.2 To start CollabCAD in Standalone mode:

Open a terminal.  Change the directory to where CollabCAD is installed. Run the
           script "collabcad" as follows:

          ./collabcad [complete_part_file_path]
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NOTE:- 

For Further help refer to the Manual by following the path 

       Start –> Programs –> CollabCAD –> CollabCAD User Manual

       Or from within the application use the menu  Help –>User Manual

6. Login

As soon as CollabCAD is started, the user needs to select the environment - Local or CMS 
and the mode - Stand-Alone or Client-Server. Default file system is "Local" and the default 
mode is "Stand-Alone". The four options are:-

i) Local and Stand-Alone
ii) Local and Client-Server
iii) CMS and Stand-Alone
iv) CMS and Client-Server

The Client-Server mode is valid if the CollabCAD Server is started.

The CMS option is only valid if the CMS server is running. [Refer to 
Content_Management_User_Manual.pdf available in the User Manual under Installation or 
Getting Started for details of how to get the CMS server started etc.]

Case i) Local and Stand-Alone :

Figure: 2

The user is prompted to select a "New" part or "Open" an existing one. No user validation 
will take place in this case.

The user can still get parts from the CMS if he selects the option File --> Open --> CMS 
Repository Parts. The user has to provide host name and port no. ( where slide is running), 
path, user id and password to validate. This is to enable him to transfer files from the CMS 
to his Local file System. In this mode, the user cannot save a part to the CMS Repository.
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Case ii) Local and Client-Server :

Figure: 3

When the user starts the CollabCAD client, it prompts for the login. Only the valid users 
can login to CollabCAD server. CollabCAD has its own user authentication system. It does 
not depend upon the OS for user authentication. Initially when the CollabCAD is installed, 
the  user  list  is  empty.  So  one  has  to  create  this  user  list  for  the  CollabCAD server 
authentication. First time this can be achieved by starting the CollabCAD client and login 
with the same name as the login id of the person who has started the CollabCAD server 
without any password. Now this person is the super user and he should add the list of 
users to the authentication system using the Admin button from the menubar. If one does 
not add the users after starting the CollabCAD client first time, then next time onwards 
others can not login, only the person whoever had started CollabCAD client first time, can 
login and of course he can add, modify or delete users at any time.

Windows: Use your Win NT / Windows 2000/XP/Vista/7 user login id with no password.

Linux: Use your Linux user login id with no password. 

The user can still get parts from the CMS if he selects the option File --> Open --> CMS 
Repository Parts. The user has to provide host name and port no. ( where slide is running), 
path, user id and password to validate. This is to enable him to transfer files from the CMS 
to his Local file System. In this mode, the user cannot save a part to the CMS Repository.

Case iii) CMS and Stand-Alone :

Figure: 4

Here the user has to provide host name, port no. ( where the CMS Server is running), user 
id password and project name. As shown in the figure this interface provide user to select 
either "Repository" or "Repository With Workflow".

If the user selects "Repository" mode he will be dealing with the simple file saving to and 
retrieving from CMS Repository.
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If  the user selects Repository with Workflow mode he can participate in the specified 
Workflow Process (Project Name).

The  workflow  process  corresponding  to  the  project  name  should  have  already  been 
created and running.

After login, one folder with the name specified by the user (as a "project name") will be 
created (if that folder does not exist previously) inside the "Project_Files" folder in the 
repository. 

A connection is made to the slide server, user authentication carried out. Now at any time 
during CollabCAD session, he can checkin checkout files without connection needing to be 
made/validated each time. At the time of exiting CollabCAD, the connection to slide server 
is closed. 

In this mode, the user can still get parts from the Local File System, if he selects the 
option File --> Open --> Local Parts. This is to enable him to transfer files from the Local 
file System to the CMS Repository. In this mode, the user cannot save a part to the Local 
File System.

Case iv) CMS and Client-Server :

Figure: 5

In this case the user has to provide host name and port no. ( where the CMS Server is 
running), user id ,password and project name. As shown in the figure this interface provide 
user to select either "Repository" or "Repository With Workflow".

If the user selects "Repository" mode he will be dealing with the simple file saving to and 
retrieving from CMS Repository.

If user selects Repository with Workflow mode he can participate in the specified Workflow 
Process (Project Name).

The  workflow  process  corresponding  to  the  project  name  should  have  already  been 
created and running.

After login, one folder with the name specified by the user (as a "project name") will be 
created (if that folder does not exist previously) inside the "Project_Files" folder in the 
repository. 
A connection is made to the slide server, user authentication carried out. Now at any time 
during CollabCAD session, he can checkin checkout files without connection needing to be 
made/validated each time. At the time of exiting CollabCAD, the connection to slide server 
is closed. 

In this mode, the user can still get parts from the Local File System, if he selects the 
option File --> Open --> Local Parts. This is to enable him to transfer files from the Local 
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file System to the CMS Repository. In this mode, the user cannot save a part to the Local 
File System.

NOTE: 
Once the CMS server is connected from CollabCAD, the connection persists for the whole 
session. If the user wants to checking a part to the repository, only the filename needs to 
be provided. Similarly for checking out a part from the repository. The default path will be 
taken to be that given at the time of making the connection. This can be edited. 

7. Description of Terminologies Used

CollabCAD uses a 3D Geometry Kernel. That is, the point is a 3D point and so are all the 
other entities like Lines,  arcs etc. Therefore the basic Modeling Philosophy followed in 
CollabCAD is 3D unlike in other Solutions where the start is 2D and then it gets into 3D 
Mode.

Work View: In view of the above, in CollabCAD one always see the 3D Work Space and 
starts with 3D Work Space. In CollabCAD Work Space always refers to 3D space. Work view 
is a display of any of the 3D spaces such as front, back, top, bottom, right, left, isometric 
or any of the user defined views. The name of the work view would be displayed in black 
color in the control panel of CollabCAD.

Figure: 6

Coordinate system:

7.1 Local Coordinate System (XT,YT,ZT)

It  is  an  auxiliary  user  defined  coordinate  system so  that  the  user  can  define  a 
Cartesian coordinate system whose XY plane is coincident with the desired plane of 
construction.

7.2 Global Coordinate System (X,Y,Z)

The global coordinate system is defined as the reference space of the model to which 
all the model geometrical data is stored. It is a Cartesian system which forms the 
default coordinate system. The X-axis will point right along the section horizontal, 
while the Y-axis will point up along the section vertical. The Z-axis is created using the 
right hand rule.
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Work Space: It is a right-handed orthogonal (composed of right angles) reference space 
in which you define entities. It is essentially a local coordinate system for defining entities 
with the origin always at (0.0,0.0,0.0).  The abbreviations XT, YT, and ZT are used 
respectively for the X, Y, and Z transform coordinate axes of the workspace. The 
name of the current workspace would be displayed in red color in the control panel of 
CollabCAD.

Work Plane: For each workspace there is a work plane. For a given workspace, the work 
plane is parallel to the XT-YT plane of the workspace and at a depth along the ZT-axis of 
the workspace. The depth of the work plane is 0.0 at the time of definition. Whenever you 
change the current depth, you specify a new work plane long the ZT-axis of the current 
workspace. The ZT coordinate of the current work plane can be read from the control 
panel of CollabCAD.

8. General Settings

8.1 Options

General settings for a Part or Session can be done using Tools->Options.

8.1.1 Session

Session options  are available  through  Tools->Options->Session  or from the  
Toolbar icon. Session options are applicable only for the current session. Session 
options are not saved.
Under  General tab, user can change the background color of the display area.  
(Figure: 7)

Figure: 7

Under  Shading tab,  using display option user can choose what all  are to be  
rendered during shading. (Figure: 8)

The various Display options are as follows:-

1. Faceted Display
2. Facets and Edges 
3. Wire Frame display
4. Hidden Line Removal (HLR)
5. HLR with Back Edges
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Figure: 8

8.1.2 Part

Part options are available through Tools->Options->Part (Figure: 9). Part options 
are applicable only for the part for/from which it is set. All part options are saved 
along with the part and are available when the part reloaded.

Figure: 9

8.1.3 Customize

Using Tools->Options->Customize user can customize the tool bar.
When the user selects the Customize menu item ,Customize tabbed pane will pop 
up . The first tab represents toolbar. (Figure: 10)

CollabCAD, National Informatics Centre   10



CollabCAD Getting Started Manual V1.0 October 2011

Figure: 10

The Toolbar panel shows the toolbar options(in check box). File, Edit, View, Basic, 
Curves, Surfaces and Solid options are available here. 
When the user selects the option(in check box), Selected toolbar dialog box will  
pop up. For Lock/Unlock the particular toolbar user need to use Mouse Right click 
operation. Locking a particular toolbar means that it will be available when you 
open the CollabCAD Application next time. (Locked toolbar - lock symbol to be  
shown in left corner, Unlocked toolbar - no symbol). (Figure: 11)

Figure: 11

8.2 Saving CollabCAD part and plot file

8.2.1 In Windows

The part and the plot file can be saved using menu  File-> Save As. The 
default  path  where  they  are  stored  is  C:\Documents and 
Settings\username\CollabCAD\parts.

8.2.2 In Linux

The part and the plot file can be saved using menu  File-> Save As. The 
default path where they are stored is  /home/username/CollabCAD/parts.
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9. Plot Configurator

Plot Configurator is a drafting application part of CollabCAD Application Software, mainly 
used to create different views of part model created in CollabCAD, applying dimensions on 
entities, creating tables, adding layers, adding symbols etc. 

Users can invoke Plot Configurator using the menu item File->Plot Configurator. This 
would invoke the full fledged Plot Configurator which enables the user to create  new plot 
files with various views of the 3D model.

In Plot Configurator using File->Print option user can print the drawing within the canvas 
on the selected printer .

Some of the general settings which needs to be done in Plot Configurator are:-

9.1     Page Setup

In File-> Page Setup, Paper size should be taken as A4.

NOTE:- As per the general practice in the industry, Paper Size is A3 but due to 
the printing constraints A4 should be used. 

9.2     Scaling

In  View-> Scale, Scale View should be  1:2 so that the views are displayed 
properly. 

9.3    Modify

In  View-> Modify,  all  the  views  will  move  together.  To modify  the  views 
individually,  untick the “View Movement Constrained” checkbox in  Tools-> 
Options.

9.4  Title

In  Tools->Title,  plotblockdata  template  can be used to  fill  Title  Data and 
Names and Dates related to the drawing.

9.5 Dimensions

Horizontal dimension can be added using menu Dimension->Horizontal.
Vertical dimension can be added using menu Dimension->Vertical.
Parallel dimension can be added using menu Dimension->Parallel.
Dimension can be deleted using menu Dimension->Delete.

10. Tool Bar

The icons available in the Toolbar are explained below:-

Icon Description

Open an existing Part.

Save the current Part. 

Print the page. 

Undo the previous operation(s). 
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Redo the last undone operation(s). 

Create point(s). 

Create line(s). 

Create rectangle(s). 

Create polyline(s). 

Create arc/circle(s). 

Create arc(s) using three points. 

Intersection between curves/surfaces. 

Modify the entity. 

Create horizontal dimensioning. 

Create vertical dimensioning. 

Create parallel dimensioning. 

Define WorkSpace 

Get the info of how many entities are there in the current part. 

Delete entities.

Delete all the entities in the current part.

Grid Snaping Enabled in the the current part. 

Grid Snaping Disabled in the the current part.

Dynamics Enabled in the the current part. 

Dynamics Disabled in the the current part.

Implicit selection Enabled in the current part. 

Implicit selection Disabled in the current part. 

Shading display Enabled in the the current part. 

Wireframe display Enabled in the the current part. 

Some Entities are masked from selection in the the current session. 

No Entities are masked from selection in the the current session. 

Measurement in mm Unit for the current part. 

Measurement in inch Unit for the current part. 
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11. Shortcut/Hot Keys

CollabCAD provides a series of Shortcut/Hot Keys to switch over to an operation. Almost all 
frequently  used  operations  are  provided  with  Shortcut/Hot  Keys.  In  most  cases  the 
Shortcut/Hot  Key  invokes  the  corresponding  operation  without  disturbing  the  ongoing 
operation. Some of the Shortcut/Hot Keys are active only during a particular operation. 

Key Description

Arrow Pan the view.

C Close a Polyline (During Polyline creation).

Ctrl + Mouse  Performs Dynamic Zooming, Panning and Rotation

D Change Depth.

Delete Delete Entity.

Enter Complete Entity Selection.

Escape Unselect the last selected entity (Only in some operations).

F Auto Fit.

Ctrl+F Change View to Front View.

F9 Enable / Disable View Dynamic mode.

F11 Restore view

G . Enable / Disable Grid Snaping

I Enable / Disable Implicit selection.

J Scales the view by half.

K Scales the view by two fold.

R Refreshing the view while in Shaded mode.

Ctrl+R Change View to Right View.

S Shade all (Solid and Surface) entities.

Space Abort the on going operation.

Ctrl+T Change View to Top View.

V Solve the relations (constraints).

W Pan the view by screen position.

Z Zoom an area indicated by screen position.

Ctrl+\ Change View to Isometric View.
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12. Glossary

Keyword Description

Blank  Hiding

Chain selection Selection of continuous curves.

Implicit points Already existing points like midpoint or endpoint  or center point of a 
curve.

Loft Solid formed between two different cross-sections

Shade All points on a surface are displayed.

Slab Prism,thickness given to planer closed curves.

Translate Move

Trim Cut or remove

Wire frame Mainly edges are displayed
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